SQL Agent job runs, step succeeded; But produces no information in the tables

Jun 27, 2013 at 12:07 AM
So my issue starts out similar to this one:

Can get all the way through step 5 of the Configuration successfully, the command line I'm using does add data to the policy.* tables as expected if ran through PowerShell directly. Tried this both logged in with my personal account and logged in as our SQL Agent account (both are Windows auth)

When scheduling the job as a powershell script, it runs successfully, but does not update any of the tables. Truncated the base tables to be sure before running. When running through SQL Agent, no files appear to be created in the 'temp' directory

Executed as user: {domain\user}. The step did not generate any output. Process Exit Code 0. The step succeeded.

Tried this without setting an explicit proxy account, then using my sysadmin account as a proxy, and using the SQL Server service account as a proxy. Same results: The step succeeded; but no data is added to the policy.* tables.

Tried editing the powershell script, commenting out all the error 'traps'; Script still runs successfully

What could I be overlooking here? Or is there a good alternative to scheduling the script?